
Using the Diagnostic Utility

This software will test SCSI and ATAPI Travan, DAT and AIT tape drives from Seagate Technology. If your backup operations are
not functioning correctly or you would like to perform other tests directly on the tape drive, you can use this diagnostic utility to 
verify that your system is communicating with the tape drive and confirm that the drive can successfully write data to a tape and 
read it back accurately.
Before running this utility, your tape drive must be installed and all cables properly attached. Be sure to close all other 
applications, including programs running in the background such as virus checkers, before testing your drive.
IMPORTANT: Because this program writes data to tape, you will need a blank or scratch tape that does not contain information 
of value to you (except for the the Check Media Capacity or Retension functions).    This tape must be in the drive’s native format
(such as DDS-3 for a DDS-3 drive, Travan 8 for a Travan 8 drive, etc.) in order to get an accurate error count.



Customer Support

If your tape drive does not pass a test after trying multiple media, contact Seagate Tape technical support. 
World Wide Web
Extensive technical help, including troubleshooting and Frequently Asked Questions (FAQs), can be found in the Technical 
Support section of Seagate’s Web site: (www.seagate.com).
North America
For pre-recorded help on the most frequently-asked questions, dial 1-800-SEAGATE in North America.
Europe
In Europe, call toll-free as listed below (8:30 a.m. to 5:00 p.m., European Central Time, Monday through Friday). Service is 
available in English, French, German and Dutch.
Austria 0 800-20 12 90
Belgium 0 800-74 876
Denmark 80 88 12 66
France 0 800-90 90 52
Germany 0 800-182 6831
Ireland 1 800-55 21 22
Italy 1 677 90 695
Netherlands 0 800-732 4283
Norway  800-113 91
Poland 00 800-311 12 38
Spain 900-98 31 24
Sweden 0 207 90 073
Switzerland 0 800-83 84 11
Turkey 00 800-31 92 91 40
United Kingdom 0 800-783 5177
NOTE: European countries with no toll-free access should call 31-2031-67222.
      For direct FAX for European technical support questions, call 31-2065-33513.
Elsewhere
Australia 61-2-9725-3366
Singapore 65-488-7584
Hong Kong 852-2368-9918
Taiwan 886-22-514-2237
Korea 82-2-556-8241



Copyright and Trademarks

Seagate Tape Diagnostic Utility, Version 3.0
Copyright 1999, Seagate Technology, Inc. All rights reserved.



License Agreement

LICENSE AGREEMENT AND WARRANTY DISCLAIMER

Seagate reserves the right to change, without notice, product offerings or specifications.    

This is a legal agreement between you the purchaser and Seagate Technology, Inc. By accessing this program, the ("Software"), 
you agree to be bound by the terms of this agreement. If you do not agree, do not access the software.    
Seagate provides the accompanying object code of the Software and nonexclusively licenses its use to you on the following 
terms and conditions. The Software is Seagate's proprietary, copyrighted product. Seagate grants you a limited access to use 
one copy of the Software. You may not copy, distribute the Software for resale. You may not reverse-engineer, modify, rent or 
lease the Software. In addition, you may not disclose the information or data incorporated in the Software to others, in any 
format.    

You accept the Software "as is" without any warranty whatsoever. Seagate does not warrant that the Software will meet your 
requirements; that the Software is fit for any particular purpose or that the use of the Software will be error-free.    

SEAGATE EXPRESSLY DISCLAIMS ALL WARRANTIES, WHETHER ORAL OR WRITTEN, EXPRESSED OR IMPLIED, 
INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE. 
IN NO EVENT WILL SEAGATE BE LIABLE TO YOU, YOUR CUSTOMERS OR OTHER USERS IN ANY WAY BASED ON USE 
OF THE SOFTWARE, INCLUDING WITHOUT LIMITATION FOR ANY LOSS OF PROFITS, LOSS OF DATA OR USE OF THE 
SOFTWARE OR INDIRECT, INCIDENTAL, CONSEQUENTIAL, SPECIAL, OR EXEMPLARY DAMAGES ARISING OUT OF OR 
IN CONNECTION WITH THE USE OR INABILITY TO USE THE SOFTWARE.    

(C) 1999 Seagate Technology, Inc. End of License Agreement.



Detecting the SCSI/ATAPI Interface

The program will detect and list the SCSI and IDE/ATAPI adapters found on the system, including built-in chips on the 
motherboard.    They will be listed in the order found. By clicking on each tape drive displayed in the “Select a Tape Drive” list 
with the mouse pointer or arrow keys, the corresponding adapter and tape drive information will be displayed below the list.



Selecting the Tape Drive

The program will list all the Seagate tape drives found on the system. By clicking on each tape drive displayed on the list with the
mouse pointer or arrow keys, the corresponding adapter information, model number and firmware revision level will be displayed 
below the list. With the drive you wish to test highlighted, click the “Next” button to proceed to the main test screen.
To return to this screen from the main test screen, either use the “Back” button or select Change drive from the File menu.



The Log File

Each step in the diagnostic process is added to the Status Log, to provide a record of the actions.    If multiple tests are made 
during the same diagnostic session, they are appended to any existing log information, unless you clear the log by selecting 
File/New or the Back button. Additional menu selections allow log files to be saved to disk as a text file (to be later opened in this 
utility or any word processor) and/or printed.    A previously saved log file can be opened and appended to with additional test 
data.
The name of the currently-opened log file is displayed above the log window.    When the log file has not yet been saved, such as
in a new diagnostic session or when File/New has been selected, the log file name will be displayed as “Untitled.”
TIP: If the log file seems to be scrolling too slowly in Windows 98, especially when loading a saved file from disc, you can 
eliminate the problem as follows: In the Windows control panel, select Display, then the Effects tab and uncheck the box marked 
“Animate windows, menus and lists.”



Setting Data Size

When using the Test Read-Write or Test Read-Only functions, you can optionally configure the size of the test data set you wish 
to write/read by selecting Data Size from the Options menu. Enter an integer number in megabytes or gigabytes (a gigabyte is 
1000 megabytes).    If you enter a number greater than the uncompressed capacity of the tape, your test will fail when the end of 
media is reached.    Click OK after you have made your selection. If you do not set a size, the data set will automatically be 5 
megabytes.    The program will not accept any value less than 5 MB or 1 GB.
IMPORTANT: Because the Test Read-Only function reads a data pattern previously written by the Test Read-Write function, be 
sure to set the Test Read-Only data size to be the same as or smaller than the Read/Write data size.    Otherwise, you will 
receive a system error when the end of data is reached on the tape.



Retension Before Test

It is very important for Travan and minicartridges to be retensioned (quickly run the tape from beginning to end) before testing the
drive, in order to make sure that the media is packed properly. The “Retension    Before Test” function is therefore selected by 
default on the Options menu, as indicated by a checkmark next to the option (it will be unavailable for helical drives such as DAT 
and AIT). If you are running multiple tests in a row, you may wish to turn this feature off after the first test in order to save time on
subsequent passes. Any time a Travan or minicartridge drive fails a test, however, be sure to retension the tape (and/or try a new
cartridge) before re-running the test.
NOTE: It is not possible to cancel a retension operation.



Testing Your Tape Drive

When you click the Test Read-Write button, this function will run the drive test using the options you have selected in the 
Options menu. After a retension on minicartridge or Travan drives, the program will write the specified amount of repeating-
pattern data on a new or scratch tape (or 5 MB if no value is specified), then rewind and read back the data pattern to compare it
with the original. A progress bar will show the percentage completed, and an entry will be made in the log file for each action in 
the test. If the error count is below the acceptable maximum, the drive will be reported as having successfully passed the test. 
Otherwise, one or more error messages will be displayed in the log file.
NOTE:    The tape must be in the drive’s native format (such as DDS-3 for a DDS-3 drive, Travan 8 for a Travan 8 drive, etc.) in 
order to get an accurate error count.
To run another test using the same drive and append to the same log file, simply click the Test Read-Write button again.
To run the same or another test and begin a new log file, select File/New, then click the Test Read-Write button.
To run a test on a different drive, click the “Back” button or select Change Drive from the File menu.    The log file will be 
cleared, after giving you the opportunity to save it to disc.    If you want to append to the same log file with a different drive, open 
it again from the File menu.



Checking Media Capacity

When you click the Check Media Capacity button, you can find out how much of the media has been used by your data and 
how much remains. The approximate remaining uncompressed capacity will be reported in megabytes. 
NOTE: Because compression ratios vary significantly, depending upon the type of data being compressed, the remaining 
capacity is merely a rough guide to how much more data can be stored on the tape.



Retensioning

It is very important for Travan and minicartridges to be retensioned (quickly run the tape from beginning to end) before doing a 
backup or restore operation, especially when using a new tape or one that has been in storage. The Retension Tape button 
allows you to manually retension a tape. It will not be available if a helical drive such as DAT or AIT is selected.
NOTE: When doing the read-write    test on a Travan and minicartridge drive, the tape is automatically retensioned before the test
begins, unless you have turned it off in the Options menu.
NOTE: It is not possible to cancel a retension operation.



Verifying Data Interchange

By clicking on the Test Read-Only button, you can verify that a data pattern written to tape with this utility on one drive can be 
read on another drive of the same type. This is useful for confirming head alignment, proper tracking, etc. 
In order to use the Test Read-Only function, you must first use the Test Read-Write function to write a data pattern on the tape. 
Then insert the tape into another drive and select Test Read-Only. IMPORTANT: Be sure to set the Data Size in the Options 
menu to be the same as or smaller than the Read/Write data size, or else the test will fail. 
The program will read the data pattern and compare it with the original. If the error count is below the acceptable maximum, the 
drive will be reported as having successfully passed the test. Otherwise, one or more error messages will be displayed in the log 
file.
NOTE: If you have run the Hardware Compression Test on this media since the last Test Read-Write operation, you must repeat 
the Read-Write test before doing the Read-Only, since the compression test will have written a different data pattern on the tape.



Log File Operations

Each step in the diagnostic process is added to the Status Log as it is completed.    If multiple passes are made during the same 
session, they are appended to any existing log information currently displayed. From the File menu, you can select:
New to clear the currently-displayed log and start a new one
Open to open a previously-saved log file in order to read it or append to it with a new test
Save to save the current log file to disc in standard text format (to be later opened in this utility or any word processor)
Save As to save the current log file by another name or to another directory
Print to print the current log file to the default printer



Verifying Hardware Compression

In order to confirm that your tape drive’s hardware data compression is functioning properly, click the Test Hardware 
Compression button on the main test screen. (NOTE:Travan tape drives do not support hardware data compression unless they
are in the “NS” series.) The program will write compressible data to a blank or scratch tape in order to verify that hardware 
compression is functioning properly.    
In normal drive operation with a backup application, the amount of data compression you gain is highly dependent upon how 
compressible your files are. For example, a bitmap image or database is highly compressible, while a program file is not. 
Compressing files that are already compressed, such as Zip files, can actually increase their size.
NOTE: The Hardware Compression Test writes a different data pattern on the tape than the Read-Write test.    If you have tested 
the hardware compression after the Read-Write test, be sure to repeat the Read-Write test before trying a Read-Only test. 



Drive Tests

After selecting your tape drive, you can perform the following tests:
Read-Write Test: This will write data to a new or scratch tape, then read it back and compare it to the original pattern to verify 
proper drive operation.
Read-Only Test:    This will read a data pattern previously written by the Read-Write Test.    It is useful to verify data interchange 
between two drives of the same type.
Check Media Capacity: This will report approximately how much uncompressed capacity is remaining on the tape currently 
inserted into the drive. 
 Test Hardware Compression:    This will confirm that hardware compression is functioning normally on a drive that supports this 
feature.
In addition, you can retension a Travan or minicartridge tape to insure proper backup and restore operation.




